Discussion:
Nie mogę zainstalować .NET Framework 3.5
(Wiadomość utworzona zbyt dawno temu. Odpowiedź niemożliwa.)
JU
2009-01-14 14:11:49 UTC
Windows XP Home+SP3+wszystkie aktualizacje

Nie mogę zainstalować .NET Framework 3.5

Podczas instalacji pobieranie składników z internetu przebiega bez
zakłóceń, ale po rozpoczęciu instalacji po chwili instalator Framework
wyświetla mi komunikat:
".NET Framework has encountered a problem and needs to close. We are
sorry for the inconvenience."
Pod spodem:
"If you were in the middle of something, the information you were
working on might be lost."
i przycisk "Close"
Po wciśnięciu "Close" kolejny komunikat:
"Produkt Microsoft .NET Framework 3.5 napotkał problem podczas
instalacji. Instalacja nie została ukończona poprawnie."
- czyli przetłumaczenie na polski.

Sprawdzałem, że mam zainstalowane:
.NET Framework 1.0 Polish Language Pack
.NET Framework 2.0 Pakiet języka polskiego
.NET Framework 2.0 Service Pack 1

Microsoft Windows Update nie wykazuje konieczności instalowania
czegokolwiek, a ja muszę mieć .NET Framework 3.5 do działania jednego z
programów.

Proszę o pomoc.
--
Pozdrawiam: JU
Piotr Palusiński
2009-01-14 16:11:57 UTC
Post by JU
Windows XP Home+SP3+wszystkie aktualizacje
Nie mogę zainstalować .NET Framework 3.5
Podczas instalacji pobieranie składników z internetu przebiega bez
zakłóceń, ale po rozpoczęciu instalacji po chwili instalator Framework
".NET Framework has encountered a problem and needs to close. We are
sorry for the inconvenience."
"If you were in the middle of something, the information you were
working on might be lost."
i przycisk "Close"
"Produkt Microsoft .NET Framework 3.5 napotkał problem podczas
instalacji. Instalacja nie została ukończona poprawnie."
- czyli przetłumaczenie na polski.
.NET Framework 1.0 Polish Language Pack
.NET Framework 2.0 Pakiet języka polskiego
.NET Framework 2.0 Service Pack 1
Microsoft Windows Update nie wykazuje konieczności instalowania
czegokolwiek, a ja muszę mieć .NET Framework 3.5 do działania jednego z
programów.
Proszę o pomoc.
Zainstaluj recznie lub
http://groups.google.pl/group/pl.comp.os.ms-windows.vista/browse_thread/thread/275f9651e09536a3?q=Problem+z+instalacj%C4%85+.NET+Framework+3.5+palusi%C5%84ski
--
Piotr Palusiński [Microsoft MVP Windows Desktop Experience]
https://mvp.support.microsoft.com/profile/Piotr.Palusinski
news://msnews.microsoft.com/microsoft.public.pl.windows
Nigdy nie kłóć się z głupcem, bo ludzie mogą nie dostrzec różnicy
JU
2009-01-14 18:53:27 UTC
Z tego tak wynika, to jest lekarstwo na te bolączki.
Przy próbie odinstalowania Framework 1.0 i Framework 2.0 Service Pack 1
otrzymuję komunikat:
"Nie można otworzyć pakietu poprawek. Zweryfikuj, czy pakiet poprawek
istnieje i masz do niego dostęp lub skontaktuj się z producentem..."
I oba dalej figurują na liście zainstalowanych.
Jak mam przeprowadzić tę "weryfikację"? Gdzie tego szukać?
--
Pozdrawiam: JU
Piotr Palusiński
2009-01-14 19:22:16 UTC
Post by JU
Z tego tak wynika, to jest lekarstwo na te bolączki.
Przy próbie odinstalowania Framework 1.0 i Framework 2.0 Service Pack 1
"Nie można otworzyć pakietu poprawek. Zweryfikuj, czy pakiet poprawek
istnieje i masz do niego dostęp lub skontaktuj się z producentem..."
I oba dalej figurują na liście zainstalowanych.
Jak mam przeprowadzić tę "weryfikację"? Gdzie tego szukać?
Jesli skasowałeś zainstalowane poprawki w katalogu Windows, to poprawki nie
odinstalujesz.
http://www.microsoft.com/communities/newsgroups/en-us/default.aspx?dg=microsoft.public.pl.windowsupdate&tid=1edc16af-e910-4bb7-894b-07084678ce90&p=1
--
Piotr Palusiński [Microsoft MVP Windows Desktop Experience]
https://mvp.support.microsoft.com/profile/Piotr.Palusinski
news://msnews.microsoft.com/microsoft.public.pl.windows
Nigdy nie kłóć się z głupcem, bo ludzie mogą nie dostrzec różnicy
JU
2009-01-14 20:21:58 UTC
Post by Piotr Palusiński
Jesli skasowałeś zainstalowane poprawki w katalogu Windows, to poprawki
nie odinstalujesz.
Troszkę pomogło "Revo uninstaler" (usunięcie zapisów w rejestrze
znalezionych przez Revo) a następnie instalacja z Framework 3.5 SP1
zamiast z samego Framework 3.5
Teraz na liście "Dodawanie i usuwanie programów" mam tych Framework-ów
wiele:
Framework 1.1
Framework 1.1 Polish Language Pack
Framework 2.0 SP2
Framework 2.0 SP2 Language Pack PLK
Framework 3.0 SP2
Framework 3.0 SP2 Language Pack PLK
Framework 3.5 SP1
Czy mają wszystkie pozostać?

Microsoft Update znajduje mi jeszcze do zainstalowania "Framework 3.0
pakiet językowy dla komputerów z procesorem x86 (KB928416)"
ale nie daje rady go zainstalować.
Czy ten pakiet jest potrzebny? Czy można bez niego się obejść?
(Program który potrzebował Framework 3.5 udało sie zainstalować bez
problemów.)
--
Pozdrawiam: JU
Piotr Palusiński
2009-01-14 20:45:07 UTC
Post by JU
Post by Piotr Palusiński
Jesli skasowałeś zainstalowane poprawki w katalogu Windows, to poprawki
nie odinstalujesz.
Troszkę pomogło "Revo uninstaler" (usunięcie zapisów w rejestrze
znalezionych przez Revo) a następnie instalacja z Framework 3.5 SP1
zamiast z samego Framework 3.5
Teraz na liście "Dodawanie i usuwanie programów" mam tych Framework-ów
Framework 1.1
Framework 1.1 Polish Language Pack
Framework 2.0 SP2
Framework 2.0 SP2 Language Pack PLK
Framework 3.0 SP2
Framework 3.0 SP2 Language Pack PLK
Framework 3.5 SP1
Czy mają wszystkie pozostać?
Tak, pozostawić, są one wszystkie potrzebne
Post by JU
Microsoft Update znajduje mi jeszcze do zainstalowania "Framework 3.0
pakiet językowy dla komputerów z procesorem x86 (KB928416)"
ale nie daje rady go zainstalować.
Czy ten pakiet jest potrzebny? Czy można bez niego się obejść?
(Program który potrzebował Framework 3.5 udało sie zainstalować bez
problemów.)
Powinna byc zainstalowana, ale jak robi opory, to ja zostaw, ktoś o nią sie
upomni, jesli bedzie potrzebna.
--
Piotr Palusiński [Microsoft MVP Windows Desktop Experience]
https://mvp.support.microsoft.com/profile/Piotr.Palusinski
news://msnews.microsoft.com/microsoft.public.pl.windows
Nigdy nie kłóć się z głupcem, bo ludzie mogą nie dostrzec różnicy
JU
2009-01-14 18:25:25 UTC
Zainstaluj recznie ...
Co to znaczy "zainstaluj ręcznie"?
Mam ściągnięty plik dotnetfx35.exe wielkości 206 692 864 Bajtów więc
wygląda na cały Framework 3.5 (chociaż w trakcie instalacji jeszcze coś
pobiera z internetu). Ściągałem pełny plik instalacyjny z kilku źródeł,
i za każdym razem był identyczny.

Czy przed instalacją Framework 3.5 należy wyinstalować wszystkie
wcześniejsze wersje Framework?
--
Pozdrawiam: JU
Piotr Palusiński
2009-01-14 18:32:36 UTC
Post by JU
Zainstaluj recznie ...
Co to znaczy "zainstaluj ręcznie"?
Mam ściągnięty plik dotnetfx35.exe wielkości 206 692 864 Bajtów więc
wygląda na cały Framework 3.5 (chociaż w trakcie instalacji jeszcze coś
pobiera z internetu). Ściągałem pełny plik instalacyjny z kilku źródeł,
i za każdym razem był identyczny.
Czy przed instalacją Framework 3.5 należy wyinstalować wszystkie
wcześniejsze wersje Framework?
Z tego tak wynika, to jest lekarstwo na te bolączki.
--
Piotr Palusiński [Microsoft MVP Windows Desktop Experience]
https://mvp.support.microsoft.com/profile/Piotr.Palusinski
news://msnews.microsoft.com/microsoft.public.pl.windows
Nigdy nie kłóć się z głupcem, bo ludzie mogą nie dostrzec różnicy
Chichotek
2009-01-14 17:58:24 UTC
Post by JU
Microsoft Windows Update nie wykazuje konieczności instalowania
czegokolwiek, a ja muszę mieć .NET Framework 3.5 do działania jednego z
programów.
Ściagnij instalke z innego źródła, ja miałem podobnie.
--
Pozdrawiam, Chichotek
P5Q Pro, ***@Scythe Ninja, Szafir HD4870 512MB, 2x2GB A-Data Vitesta 800+,
2x Seagate 250/400GB, Topower P3 450W EZ, Enermax Chakra, 21" Gateway,
Razer DeathAdder+Destructor, Logitech UltraX Flat, Windows XP Pro